benway.net
Wordpress 2.5.1, not too bad | Benway Net
Well out of all the plug-ins I use here on benway.net only 3 of them don’t seem to want to work with the new version. I’d also like to find a new theme to support the new builtin gravatar features.