oneminutemacman.com
How to make the annoying "To use the java command-line tool you need to install a JDK" pop-up go away forever - One-Minute Macman
The "java command-line" pop-up is improperly linked at Apple.com. To make it go away, you need to install an older version of Java. Here's how.