blog.fictionpress.com
FireFox Compatibility Fix
We have resolved a new issue with Firefox users receiving cryptic errors. We encourage all Firefox users to upgrade to the latest 34.0.5 desktop version.