blog.does-not-exist.org
mutt-1.2.5.1 and mutt-1.3.25 have just been simultaneously released.
These releases both fix a security hole which can be remotely exploited. The problem was found and a fix suggested by Joost Pol