atmaxplorer.com
Install PSP Custom Firmware 5.03 Prometheus add-on
If you had 5.03 GEN-C and you’ve probably experienced having problems playing games with Sony’s new DRM which requires 6.20 OFW. Luckily, Liquidzigong created Prometheus Module so that users with 5.03 GEN-C (meaning COMPLETELY hackable PSPs) can still enjoy the latest game releases without ...