akvabit.jp
Zen Cart の php5.3対応 | Case Of Akvabit
このたび、Zen Cartを御客様に納品すべく作業する中、php5.3で動作させることに成功 いたしました。Zen Cartの最新版がphp5.3で動作せず、困っていらっしゃる方が多数お られるようですので、以下に対応内容を記しておきます。 なお、Zen Cartのインストール先はホームディレクトリの一階層したです。以下のUrl 表記において /****/という伏字で表示いたします。 1.インストールサーバー  ・大塚商会 アルファメールダイレクト(通常のアルファメールもMySQL、phpのヴァー   ジョンは同一なので動作すると思います)   php 5.3.2   MySQL 5.1.47 2.ダウンロードしたzen-cart のバージョン      zen-cart-v1.3.0.2-l10n-jp-6.zip 3.インストール時、サーバ内部エラー発生   エラーログ内容:     ~/****/.htaccess: php_flag not allowed here   原因:****/.htaccess  該当箇所をコメントアウト   #  # php_flag register_globals Off  #  #  # php_flag register_globals Off  # 4.インストール時、Deprecated: Function ereg() is deprecated in ・・・    のエラー多発。   PHP5.3への未対応が原因。   以下の4ファイルを修正(※エラー出力を制御)   (1)admin/includes/application_top.php(49行)    error_reporting(E_ALL & ~E_NOTICE);     ↓    error_reporting(0);   (2)includes/application_top.php(44行)    error_reporting(E_ALL & ~E_NOTICE);     ↓    error_reporting(0);   (3)zc_install/techsupp.php(42行)    error