qso365.co.uk
If you use WSJT-X for FT8/WSPR/JTx etc, you should upgrade to V2.0.0 as soon as possible
WSJT-X version 2.0.0 has been released and everyone who uses this software for any data modes should update as soon as possible. This new version is NOT compatible with previous versions so everyo…