johnmclaughlin.info
Well, that sucked
Apparently, even though I upgraded my wordpress install to avoid the vulnerability found last Oct/Nov, I got ‘hacked’ all the same.