geeksterminal.com
[How To] Install Skype 4.3 on Ubuntu 10.04/12.04/12.10/13.10/14.04 - Geeks Terminal
Skype has stopped supporting older version than 4.3 due to the new security implementations. This ha