sololinux.es
Instalar y configurar PHP con OCI8
Para habilitar la extensión OCI8 se ha de configurar PHP con la opción --with-oci8 . Antes de iniciar el servidor web, OCI8 normalmente necesita diversas variables de entorno de Oracle para localizar bibliotecas, apuntar a ficheros de configuración, y establecer algunas propiedades básicas como el conjunto de caracteres usado por las bibliotecas de Oracle. Las variables deberían ser establecidas antes de que se inicie cualquier proceso de PHP. PHP debería ejecutarse con la misma, o más reciente, versión mayor de las bibliotecas de Oracle con las se se configuró. Por ejemplo, si se construyó OCI8 con las bibliotecas de Oracle 11.2, entonces PHP debería también PHP usarse y ejecutarse con la bibliotecas de Oracle 11.2.
Sergio G.B.