Configuring Dell EqualLogic PS6500 Array to work with RedHat Linux 6 EL

I decided to write the following post after having some problems getting iSCSI connectivity to work correctly with a Dell EQL PS6500 Array with RedHat 6.

It seems that Dell have done a great job in getting the Host Integration Tools to work with RH5.5 and ESXi and also the MEM for MPIO and I love the product, but I encountered some problems when trying to install a RH6 server and connect it all up following the docs on the Dell site. The main issue I had straight way that I was predominantly using SuSE SLES as my preferred Enterprise distro, but the RPMs provided by Dell for the HIT tools and MPIO had a load of dependencies that needed to be resolved before it was even possible to start using the extended functionality that these tools offer on SuSE.

So I downloaded a version of RH6.1 to test the new tools on, only to find that this didnt work as intended. After a lengthly support call, I was told that although the documentation said that it supported RH6 what this actually meant was 6.0. – So I downloaded 6.0 and had exactly the same issues…

So I did some digging around and debugging of the installation procedure and docs. The first thing that the docs tell you to do is make sure that you are at the latest supported release of 6 and to perform a yum_update. – This in itself is a problem, as it effectively takes the 6.0 installation and makes it 6.1. I tested this once I had a working 6.0 installation by doing the yum_update, and it completely broke the ability to address the iSCSI devices properly using the Dell tools. I found this a bit worrying, particularly if you are sharing your admin roles with someone else, they could inadvertently break the entire configuration.

The instructions for actually formatting and adding the device to the system seem to be a bit flaky at best, and I couldnt help feeling that somewhere there must be a ‘missing manual’

The documentation(for RedHat MPIO on EQL) states as a final step that you need to do the following(this is entirely absent from the HIT tools docs):

mke2fs –j –v /dev/mapper/rhel-test

this doesnt work at all using the HIT tools and tells you that the process could not read block 0, and gives you all sorts of wonderful messages about not being happy with the superblocks on the device. – This doesnt happen if you dont use the tools, but just use Linux native MPIO.

The only approach to this that worked, which was not resolved by my support experience, but by trial and error on my part (which was very time consuming) was as follows. Here’s my checklist:

Configure SCSI on the local onboard NICS on a dedicated DELL R710 and set 4 paths (edit the /etc/equallogic/equallogic.conf file and change the [MPIO] section to contain the maximum amount of path (NICS) you intend to use) – If you dont do this you could have problems in the future as for each NIC path you are given a corresponding /dev/sdX device which sits behind the mapper tool.

Some issues with the Dell HIT tool for EQL it doesnt work well on 6.1.

Yum update from 6.0 breaks a valid config as it effectively takes the server to 6.1!!!

Ignore the doc, dont do a localinstall of DKMS,EQL and iscsi-initiators. Also dont grab the latest version of DKMS as it is broken even though its available on the Dell site. – at the time of posting I used dkms-2.1.1.2-1.noarch.rpm, but had problems with dkms-2.2.0.0-1.noarch.rpm.

Grab kernel-devel and gcc, gcc-headers using yum

Configure iscsi.conf and CHAP. – enter in here the CHAP password you set on your EqualLogic

Enable iscsi logins in /etc/rc.local

Run eqltune -v and run through checklist and make the necessary alterations to the kernel config,etc. – This tool is your friend!

Run ehcmcli -d to show valid paths and sessions (you should see 4 paths here if you set your MPIO settings in /etc/equallogic/equallogic.conf  to 4).

Run rswcli -E -network <ip> -mask 255.255.255.0 to exclude the public NICS from accepting broadcast traffic from the EQL tool.

Use iscsiadm to discover the new LUNS and to log in the EQL LUN.

Next look in /dev/mapper for the eql-xxxxxxxx-volname LUN id. Make a note of its true dm-X number

To format the disk do not use the MPIO device. Its necessary to format the sdX devices that are available on each session. for this reason as well it means you need to set the config ahead of time at its maximum. It wont create more sessions as they are needed (this will break the LUN!!!). do this in /etc/equalogic/eql.conf

Run ehcmcli to find out which sdX devices are underneath the MPIO layer.

next run:

kpartx -a /dev/dm-X (where dm-X is the dm id associated with the eql LUN and vol name)

sfdisk /dev/sdXX (do this for each sdX)

kpartx -a /dev/dm-X

Next: mkfs.ext3 /dev/mapper/eql-lun-vol-part

mount /dev/mapper/eql-lun-vol-part

I’ve also included my working multipath.conf file from my attempts to use native MPIO on RH6.1 and not the Dell tools. You will note that the way that the scsi tools (on RH6.1) interrogate the device has changed slightly and it now expects to see SEQLOGIC not EQLLOGIC, which could explain why the yum update breaks the tool.

There is also the suggestion to do the following in the lvm.conf file, but this renders you install unbootable if you are using LVM on your main filesystem.

filter = [ r|/dev/mapper/eql-[-0-9a-fA-F]*_[a-z]$| ]

/etc/multipath.conf

defaults {

        udev_dir                /dev

        polling_interval        10

        path_selector           “round-robin 0″

        path_grouping_policy    multibus

        getuid_callout          “/lib/udev/scsi_id –whitelisted –device=/dev/%n”

        prio                    const

        path_checker            directio

        rr_min_io               100

        flush_on_last_del       no

        max_fds                 8192

        rr_weight               priorities

        failback                immediate

        no_path_retry           fail

        queue_without_daemon    no

        user_friendly_names     yes

        mode                    644

        uid                     0

        gid                     disk

}

blacklist {

        devnode “^sd[ab]$”

        devnode “^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*”

        devnode “^hd[a-z][[0-9]*]”

}

#blacklist_exceptions {

#       devnode “^dasd[c-d]+[0-9]*”

#       wwid    “IBM.75000000092461.4d00.34″

#}

multipaths {

        multipath {

                wwid                    36090a0a890d37ea5f1df5414000040ac

                alias                   MyRedHatVol

        }

}

devices {

 device {

        vendor “SEQLOGIC”

        product “100E-00″

        path_grouping_policy multibus

        getuid_callout “/sbin/scsi_id -p 0×83 -gus /block/%n”

        features “1 queue_if_no_path”

        path_checker readsector0

        failback immediate

        path_selector “round-robin 0″

        rr_min_io 10

        rr_weight properties

}

}

I’m sure theres other ways to sort this out, but the above checklist is what worked for me..

DELL PowerConnect iSCSI config for ESXi and EqualLogic

When I was learning how to do this I couldn’t find a straightforward guide on the web, so I decided to write some simple notes as I was configuring these at a customer’s site today in the hope this might help someone else.

In my scenario I have two DELL PowerConnect 6224 switches with stacking cards and cables. The goal here is to configure these to provide iSCSI networking for ESXi and an EqualLogic SAN.

I’ve split the ports between iSCSI and vMotion and left a couple of ports on each switch for management purposes. Tailor the commands as you see fit for your own needs. Lets get started…

Rack and stack the switches, power them on with no ethernet cables connected 

Connect console cable, reload and run through setup wizard

Assign an IP address for management to the switch stack, reserve/exclude it from DHCP

Plug your laptop into port 23 on one of the switches

Connect to web interface using the management IP you gave the switch earlier to ensure all is well and check the switch firmware version

Download the latest firmware from DELL, extract the stk file to your TFTP server (use Solarwinds if you need one)

On console of the stack, run:

copy tftp://TFPSERVERADDRESS/FIRMWARE.stk image

When file transfer has completed the firmware will get distrubuted to all switches in the stack. Once completed, check version numbers:

show version

Image2 should have the latest firmware version installed. Activate this:

boot system image2

update bootcode

The switch will update and reboot automatically. When complete, check the versions again:

show version

They should now be using the latest firmware via image2.

Set the timezone and a hostname of the stack:

enable

configure

clock timezone 0 zone “utc”

hostname “StackName-iSCSI-Stack”

exit

To configure VLANs for iSCSI, vMotion I did the following:

enable

configure

spanning-tree mode rstp

flowcontrol

vlan database

vlan 100

exit

vlan 200

exit

interface vlan 100

name “iSCSI”

routing

ip address 172.16.100.1 255.255.255.0

exit

interface vlan 200

name “vMotion”

routing

ip address 172.16.200.1 255.255.255.0

exit

interface range ethernet 1/g1-1/g12

storm-control broadcast

storm-control multicast

storm-control unicast

description “iSCSI”

mtu 9216

switchport access vlan 100

exit

interface range ethernet 2/g1-2/g12

storm-control broadcast

storm-control multicast

storm-control unicast

description “iSCSI”

mtu 9216

switchport access vlan 100

exit

interface range ethernet 1/g13-1/g22

storm-control broadcast
storm-control multicast
storm-control unicast
description “vMotion”
mtu 9216
switchport access vlan 200

exit

interface range ethernet 2/g13-2/g22

storm-control broadcast
storm-control multicast
storm-control unicast
description “vMotion”
mtu 9216
switchport access vlan 200

exit

interface range ethernet 1/g23-1/g24
channel-group 1 mode auto
storm-control broadcast
storm-control multicast
storm-control unicast
mtu 9216
exit

interface range ethernet 2/g23-2/g24
channel-group 1 mode auto
storm-control broadcast
storm-control multicast
storm-control unicast
mtu 9216
exit

interface port-channel 1
description “Management-Ports”
mtu 9216
exit

iscsi enable

copy running-config startup-config

You now want to back up your configuration via TFTP:

copy startup-config tftp://TFPSERVERADDRESS/conf.cfg

With a bit of luck you’ll be all done. Good luck!

SimpliVity gets $25M to push its super appliance

#SuryaRay #Surya Startup SimpliVity has raised $25 million to staff up engineering, support and marketing efforts as it prepares to ship its OmniCube ”super appliance” in the fourth quarter.

SimpliVity CEO Doron Kempel.

Kleiner Perkins Caufield & Byers led the Series B round which also includes contributions from existing backers Accel Partners and Charles River Ventures. The new cash brings total funding to $43 million for the company which was founded in 2009 but emerged from stealth mode in August.

With Omnicube, SimpliVity claims it can cram up to 10 separate functions including WAN optimization, deduplication and backup into a single 2U box that runs the company’s software and uses a hardware accelerator to speed up data writes. OmniCube should be available in the fourth quarter, perhaps by late November, SimpliVity CEO Doron Kempel told me in an interview.

SimpliVity’s pitch is that if  one appliance that combines two or three workloads is good, one that melds 8 or 10 workloads is better. For mid-market companies without a ton of in-house IT personnel, the tasks of managing servers, storage switches, primary storage, back-up and deduplication appliances can be too much. OmniCube puts all that together into one box that can be managed by the VM administrator.

The Westborough, MA-based vendor plans to sell all of its appliances through VARs and integrators, Kempel said, adding that Rick Shea, SimpliVity’s VP of sales and support, once directed EqualLogic’s successful channel-friendly sales model.

There are lots of data center appliances available — from HP, IBM and Cisco — all primarily legacy hardware vendors targeting enterprise accounts. SimpiVity’s focus on the mid market and the fact that it’s a startup that doesn’t have to worry about cannibalizing sales of older products, differentiates it. That and the fact that it has deep funding and good technology DNA –its execs come from Dell, EqualLogic, EMC, and IBM — mean it’s got a pretty good foundation on which to build.

_Feature photo courtesy of Flickr user  Tracy O_

http://dlvr.it/2CRkSZ @suryaray
Growing our data center

Aircraft Inventory has always prided itself on leveraging technology in the workplace to make our company stronger. Today we added an additional array to our data center doubling our existing high-speed data storage for SQL databases and virtual machines. The new array will allow Aircraft Inventory to continue offering valuable tools to our customers like real-time inventory availability,  and “anywhere” access from our mobile app.  The new array not only doubles current storage capacity but also offers an estimated 3x increase in data access speeds. 

image

The Details

The new array is an EqualLogic 6100xv filled with 24x 15,000 RPM 600 Gigabyte drives to give an available disk capacity of 5.8 Terabytes. 

7 Observations From a Woman in Tech - Paula Long

                 

Dell acquired co-founder Paula Long’s storage area networking company EqualLogic for $1.4 billion in 2007 – history’s largest all-cash payout for a venture-backed startup.

Hear Paula Long’s non-linear path to entrepreneurship and her 7 observations about how to succeed as a woman in technology here: http://www.women2.com/7-observations-from-a-woman-in-tech-paula-long/

iSCSI, VMware recommended reading

If you are setting up a VMware environment using iSCSI storage (especially EqualLogic) then I recommend reading these links:

And some tips when configuring your VMware storage…

  • Keep your VM swap files with the VM.
  • Use shared LUNs, only use a LUN per VM when performance or security requires it.
  • Make your shared LUNs at least 500GB.
  • Keep a maximum of 15-20 VMs on each LUN.
  • Use the Software iSCSI adaptor, jumbo frames aren’t supported in VMware on hardware adaptors and you’ll get much more performance from jumbo-frames than from offloading iSCSI processing to a HBA - see benchmarks.
  • But if you need to boot from an iSCSI volume then you’ll have to use a hardware adaptor.
  • Set Round-Robin MPIO policy on each volume.

Finally, see my previous post about configuring VMware ESXi iSCSI software adaptor via PowerShell.

DataGravity Says It’s Time For Your Storage to Smarten Up Already

image

By Barb Darrow

DataGravity, the thus-far secretive startup co-founded by Paula Long of EqualLogic fame, is finally ready to talk about its DataGravity Discovery storage array.

Lately, much of the discussion around storage has been about speeds and feeds of the latest flash arrays — and that’s valid. But Long’s position is that much of the value of what companies store is lost because that data goes into a black box, and companies have to deploy audit software and other extras it to wring important information out of it. DataGravity integrates those tools, search and analytics, into its software.

Read More

Nashua startup DataGravity enters the market helping firms make sense of ‘big data’

NASHUA – One of the city’s highest-profile startups, DataGravity, has released its first product, designed to help mid-sized firms make sense of and learn from the deluge of data that is part of modern business. The firm has drawn attention since it first opened in temporary quarters on Spit Brook Road because it founded by two of the people who created EqualLogic, a Nashua-based storage networking startup that was bought in 2008 by Dell for $1.4 billion. In May, as reported by The Telegraph, it moved into a permanent home on Innovation Way. On Tuesday, Aug. 19, it left “stealth mode,” announcing DataGravity Discovery Series, which it calls the first “data-aware storage platform that tracks data access and analyzes data as it is stored to provide greater visibility, insight and value from a company’s information assets …



Nashua startup DataGravity enters the market helping firms make sense of ‘big data’
EqualLogic Co-Founder Paula Long's Latest Startup, DataGravity ... - Wall Street Journal (blog)


Wall Street Journal (blog)

EqualLogic Co-Founder Paula Long’s Latest Startup, DataGravity …
Wall Street Journal (blog)
Serial entrepreneur Paula Long, one of the few females who has started hard-core technology companies that sell products to businesses, released more details on her latest venture—DataGravity Inc., a startup that is using technology to bring …

тощо »

Text
Photo
Quote
Link
Chat
Audio
Video